Myrja.Schumacher

Which Inventory agents are compatible with Inventory Server versions 5 and 6 respectively.

Blog Post created by Myrja.Schumacher Employee on Mar 7, 2019

The rule of thumb is that we always strive to make the Inventory Server backward compatible with older Inventory agents. The reasoning behind this is that it could be costly (both time and money) to update all agents at a customer while the server can be updated relatively easy using SUS.


On the other hand, an Inventory Server may not stay “future-compatible” when newer agents are released, although we try to keep as much compatibility as we can.


A recent example of when compatibility has been broken is with the macOS 6.0.0 agent. As this macOS agent support macOS Mojave with new technology for NVMe-disks and APFS file system, the way that disk information was reported by the agent needed big changes in the schema. This means that the macOS Agent 6.0.0 and later will require Inventory Server version 6.0.0 or later.


Since we were able to keep “future-compatibility” for all other agents, the following matrix summarizes the compatibility:

Agent Version

Required Server version

Windows agent 5.0.0-6.0.2

Inventory server 5.0.0 or higher

Linux agent 5.0.0 - 6.0.0

Inventory server 5.0.0 or higher

Unix agent 5.0.0 -6.0.2

Inventory server 5.0.0 or higher

macOS 6.x

Inventory server 6.0.0 or higher

macOS 5.x

Inventory server 5.0.0 or higher

Bottom line: Running the latest Inventory Server always ensures maximum compatibility.

Joel Sanderi, Product Owner 

Outcomes