AnsweredAssumed Answered

SnowAgent issue (Win10?)

Question asked by Snow-good on May 1, 2019
Latest reply on Jul 19, 2019 by LarsReifegerste

I should know the answer:

 

We do not have a snow expert.  I was involved in the initial set up and installation and subsequently I'm deemed to be our go to person..  I don't mind this, but when I begin to struggle with my own machine and Snowagent issues and I can't deal with them I feel well out of my depth.   

 

I've had snow agent 5 running on over 3000 devices reporting as expected, but after running a recent "Computer" report I notice my own, and a handful of other computers reporting as "Quarantined"

When I looked in C:\Program Files (x86)\Snow Software\Inventory\Agent\data I noticed *.json files dating back months had a look through the local log files and was nothing untoward.  I ran a CMD prompt with elevated privileges and run the manual commands.

Snowagent Stop  

Snowagent start

Because there were already lots of .json files I didn't initially run scan, but just try to send.  The command accepted but nothing occurred. So I ran:

Snowagent scan

C:\Program Files (x86)\Snow Software\Inventory\Agent>winver

C:\Program Files (x86)\Snow Software\Inventory\Agent>snowagent scan

C:\Program Files (x86)\Snow Software\Inventory\Agent>New-Object : The term 'New-Object' is not recognized as the name of a cmdlet, function, script file, or operable out-lineoutput : Win32 internal error "Access is denied" 0x5 occurred while reading the console output buffer. Contact
Microsoft Customer Support Services.
+ CategoryInfo : ReadError: (:) [out-lineoutput], HostException
+ FullyQualifiedErrorId : ReadConsoleOutput,Microsoft.PowerShell.Commands.OutLineOutputCommand

 

When I tried the same thing again but ran CMD as a Domain Admin I got the following error message:

C:\Program Files (x86)\Snow Software\Inventory\Agent>snowagent scan
2019-05-01T09:03:15+01:00; Info; <--OPENMSG-->; ;;; Snowagent version 5.2.4
2019-05-01T09:03:15+01:00; Verbose; snowagent; snowagent\main.cpp; SetupConfigurationAndLogging; Using external configuration file: snowagent.config
2019-05-01T09:03:15+01:00; ERROR; snowagent; snowagent\main.cpp; wmain; Fatal error: Cannot create lockfile handle (insufficent file access privileges?).
Fatal error: Cannot create lockfile handle (insufficent file access privileges?).

 

I can't see anything obvious and don't understand why its working on more machines than it isn't?  Can anyone point me in the right direction for fault finding?

 

Many thanks

 

 

 

NB.  We have 27 Windows 10 PC's of which only 8 are successfully reporting.  They are on the same subnet, share the same pushed snow.config details.

Outcomes