AnsweredAssumed Answered

GLIBC_2.7 dependency?

Question asked by cvillabrille on Sep 16, 2019
Latest reply on Sep 18, 2019 by ester.memoli

We are installing Snow Agent 6.1 in Centos 5 (CentOS release 5.5). When we try to run manually (or through the cron job) the snow agent, we receive the following error:

 

/opt/snow/snowagent: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by /opt/snow/snowagent)

 

(our glibc version is 2.5  in Centos 5)

 

I have checked the compatibility matrix and installation manual, and there is no reference on both to any dependency on any specific GLIBC version, and also, Centos 5 is under the supported platforms by the agent as per the support page (Snow_Agent_CompatibilityMatrix.pdf.pdf )

 

Do we have to install only the Snow agent version 5? If so, are we going to have any incompatibility when we will upgrade the server (to version 7 for instance) having the agent 5 deployed?

 

Any other parallel solution to the GLIBC error? (apart from upgrading to Centos 6).

Outcomes