AnsweredAssumed Answered

Issues with XML Connector

Question asked by arbleb Advocate on Oct 3, 2017
Latest reply on Oct 25, 2017 by linda.a.smith@carestream.com

Anybody use the Snow XML connector?

 

I was told that I can manually enter non-inventoried machines via an XML file so I can track licenses on machines that we cannot scan or inventory.

 

I added the XML connector, set a path up and placed an example file I received from Support into that folder:

 

<?xml version="1.0"?>
<client>
  <biosserialnumber>123ABC</biosserialnumber>
  <hostname>COMP0002</hostname>
  <lastupdate>2015-04-09T11:04:19</lastupdate>
  <sitename>XXX</sitename>
  <clientidentifier>COMP0002</clientidentifier>
  <clienttype>0</clienttype>
</client>

 

I "Aggregate Selected" on that XML connector and it appears to consume that .xml file and it disappears from the folder.

 

In the log file I see:

 

2017-10-03 07:42:56,461 [6] DEBUG SnowSoftware.ExternalDataProvider.Aggregator [(null)] [(null)] - ProcessResourceBatch start: Snow Xml_1
2017-10-03 07:42:56,477 [6] INFO  SnowSoftware.ExternalDataProvider.Aggregator [(null)] [(null)] - Retrieving resource [D:\XMLImport\comp0002.xml].
2017-10-03 07:42:56,477 [6] INFO  Snow Xml_1 [(null)] [(null)] - Preparing to retrieve resource.
2017-10-03 07:42:56,508 [6] INFO  Snow Xml_1 [(null)] [(null)] - Beginning parsing of table [client].
2017-10-03 07:42:56,508 [6] INFO  Snow Xml_1 [(null)] [(null)] - Parsing result set client into a ClientEntity.
2017-10-03 07:42:56,539 [6] INFO  Snow Xml_1 [(null)] [(null)] - Finished execution of sql data reader.
2017-10-03 07:42:56,539 [6] INFO  SnowSoftware.ExternalDataProvider.Aggregator [(null)] [(null)] - Sending resource [D:\XMLImport\comp0002.xml].
2017-10-03 07:42:56,555 [6] INFO  SnowSoftware.ExternalDataProvider.Aggregator [(null)] [(null)] - ProcessResourceBatch end: Snow Xml_1

 

However, COMP0002 never shows up in my inventory.

 

I feel like I'm missing something critical.  Anybody have any insight?

Outcomes